独りトラブルシューティング: 2008年6月アーカイブ

今のところ会社で使っているXPだけで発生するのですが、

↓今回の主役、スタートボタン。

normal_start_button.png


スタートボタンをクリックする、またはCtrl+Escを押す、またはミ田(ウィンドウズキー)を押すと、普通スタートメニューが出ますよね。

↓こんな感じで。

normal_start_menu.png


それが、しばらく使っているといつの間にかスタートメニューが出なくなります。

↓こんな感じに。

no_start_menu.png


フォーカスはスタートボタンに移っているようなので何かしらやろうとは思っている風なのですが、ボタンの状態が違うので、たぶんスタートメニューが遥か画面の外に移動しているとかいうことではなさそうです。実際この状態でUキーとか押してもシャットダウンメニューが出たりはしないので。


こうなるきっかけはよくわかっていません。
起動直後は少なくとも普通なんですが、仕事をしているといつのまにか出なくなっていたりします。
いちど出なくなると、再起動またはログオフをするまで復活しません。

当然ですがけっこう不便です。
なんせいちいちExplorerからスタートメニューフォルダを探したりしているので、そのたびにクイック起動バーが充実していきます。
落とすときはデスクトップを一度クリックしてAlt+F4しています。


ためしたこと
  • スタートメニューがあるつもりでUキー(シャットダウンメニュー)、Pキー(全てのプログラム)などのキー操作をしてみる(スタートメニューが見えない場所へ移動していることを疑う)
    ⇒ なにも起こらない。
  • http://121ware.com/qasearch/1007/app/nec.jsp?003596 を試してみる(固定キー機能がオンになっていることを疑う)
    ⇒ 固定キー機能はオフになっていた。というか試しにオンにしてみたが挙動が違う。
  • 再起動、ログオフ
    ⇒ 直る。けどいちいちログオフするのは面倒。
  • あと何があったかな。。

システム:
Microsoft Windows XP
Professional
Version 2002
Service Pack 2

Thunderbirdには、検索フォルダという機能があります。
Gmailのラベルに似ていると言えば似ているかもしれませんが、仮想フォルダとでも言いましょうか、検索条件を指定しておくと対象のフォルダ(複数)からそれに該当するメールを引っ張り出してきて見せてくれるわけです。

職 場のThunderbirdには、「ブログとニュースのアカウントから未読のRSS記事を表示する検索フォルダ(『newblog』フォルダと命名)」、 「未読orラベルのついているメールを表示する検索フォルダ(『ToDo』フォルダと命名)」というのを作っているのですが、「newblog」を表示し た直後に「受信」フォルダやその他普通のフォルダを開くと、なぜか一部のメールが見えなくなる、という現象がこのところずっと発生して悩まされていました。いろいろ とフォルダを行き来してると、「ToDo」フォルダから通常フォルダに移ったときは普通に全部見えて、「newblog」⇒「Todo」⇒通常フォルダと 移ったときも全部見えて、「未読blog」⇒「通常フォルダ」と移ったときだけ、一部メールが見えなくなるようでした。そして、見えなくなるメールという のはいつも決まっているようでした。
長いこと原因がわからなくて、「newblog」を見たたびにいったん「ToDo」を経由して他のフォルダへ移る、ということをやっていらいらしていたのですが、このたびようやくその現象がなおりました。


ま ず「見えなくなるメール」と「見えなくならないメール」の違いは何か、ということを考えたのですが、返信メール(Re:のついたもの)は見えなくなりやす いという体感というか経験則のようなものは見いだしていました。ある時ふとThunderbirdには「スレッド表示」機能があることを思い出して、ス レッド表示をONにしたときの見え方と消えるメールとの対応を見てみたら、あろうことか「見えなくなるメール」=「スレッド表示で2階層目以下に表示され るメール」という図式がぴったりと当てはまっていました。「newblog」を表示した直後は通常フォルダではどういうわけかスレッドの親のメールしか見 えなくなる、ということのようでした。

スレッド機能が怪しいということで、検索フォルダのスレッド表示設定をいろいろいじって非スレッド 表示にしてみたところ、といってもメニュー上もチェックマークがつくでもなくフォルダの見た目上もまるで変わらないんですが、とにかくその設定を変えてみ たところ、件の「newblog」⇒「通常フォルダ」と移ったときに特定メールが見えなくなる現象はピタリとおさまってしまいました。

結 局のところ、昔適当にいじった「newblog」のスレッド表示に関する設定がどういうわけかフォルダを移っても消えずに、他のフォルダで中途半端に非ス レッド表示をしようとして見えなくなっていたようです。なぁんだという感じもしますが、なんでスレッド表示ONになっていることに気づかなかったのかって 話ですよね。
いろいろ調べてみたら、「検索フォルダはスレッド表示が可能。しかし、検索対象のフォルダが複数にまたがる場合は、スレッド表示は(設定しても)できない」ということだそうです。なんかその辺で、スレッド表示をONにしたまま忘れていたんじゃないかなと思います。
他のフォルダに移動したときに設定が消えないのは、、、バグ?


ともかく現象は治ったので、移動のたびにイーッてならずに済みそうです。

2008年10月

      1 2 3 4
5 6 7 8 9 10 11
12 13 14 15 16 17 18
19 20 21 22 23 24 25
26 27 28 29 30 31  

このアーカイブについて

このページには、2008年6月以降に書かれたブログ記事のうち独りトラブルシューティングカテゴリに属しているものが含まれています。

次のアーカイブは独りトラブルシューティング: 2008年7月です。

最近のコンテンツはインデックスページで見られます。過去に書かれたものはアーカイブのページで見られます。

2008年9月: 月別アーカイブ

ウェブページ

Powered by Movable Type 4.1